[Webkit-unassigned] [Bug 23750] Cannot resize frames because frameborder=0

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri May 4 06:33:10 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=23750





--- Comment #7 from Swapna <spottabathini at innominds.com>  2012-05-04 06:33:10 PST ---
(In reply to comment #5)
> (From update of attachment 139434 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=139434&action=review
> > Source/WebCore/ChangeLog:9
> > +     
> Any link to what the spec says about this? I mean there must be a reason for the original code
The specs say nothing about 'existence of frame border' Vs 'frame resizing'. Spec talks only about visibility of frameborder on having values like frameboder=0 and frameborder=1. And for reference FF and IE both allow resizing of the frames while frameborder=0. I suppose, it should be user friendly if we allow resize of frames even in case of frameborder=0.
interesting link:
http://stackoverflow.com/questions/7093298/allow-resizing-of-html-frames-while-adding-frameborder-0-attribute

> 
> > Source/WebCore/rendering/RenderFrameSet.cpp:671
> > -    if (split == noSplit || !axis.m_allowBorder[split] || axis.m_preventResize[split]) {
> > +    if (split == noSplit || axis.m_preventResize[split]) {
> 
> Please make sure that this is not breaking frame flattening in any way
It is not breaking frame flattening . For instance, My changes are in RenderFrameSet::startResizing , and it is getting called from RenderFrameSet::userResize.
In this RenderFrameSet::userResize function if frameFlatteningEnabled = true, it will return false and rest of the code won't be executed.


> > LayoutTests/fast/frames/frames-with-frameborder-zero-can-be-resized.html:8
> > +            if (window.layoutTestController)
> > +                layoutTestController.dumpAsText();
> > +
> > +            function log(frame, success, isWidth, size) {
> > +              if (window.layoutTestController) {
> 
> inconsistent indentation
> > LayoutTests/fast/frames/frames-with-frameborder-zero-can-be-resized.html:9
> > +                alert(frame.name + ' resized correctly = ' + (success ? 'true' : 'false'));
> 
> We normally write PASSED or FAILED, but true, false. Please check how other tests are made
> 
> > LayoutTests/fast/frames/frames-with-frameborder-zero-can-be-resized.html:24
> > +                if (!window.layoutTestController)
> 
> You have these tests all over. Why not rename init() to run() or so and add this test as the first thing.
> 
> > LayoutTests/fast/frames/frames-with-frameborder-zero-can-be-resized.html:30
> > +                    //Move the One/* vertical resizer ten pixels west...
> 
> Please add a space after // and just one punctuation mark at the end
> 
> > LayoutTests/fast/frames/frames-with-frameborder-zero-can-be-resized.html:49
> > +            function checkSuccess() {
> > +                    log(One, One.frameElement.width == 100, true, 100)
> > +                    log(Two, Two.frameElement.height == 80, false, 80)
> 
> very inconsistent indentation again

Did changes as per review comments in patch-III

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list