[Webkit-unassigned] [Bug 85575] [BlackBerry] Autofill backing store implementation upstream

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri May 4 04:49:44 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=85575


Rob Buis <rwlbuis at gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #140169|review?                     |review-
               Flag|                            |




--- Comment #2 from Rob Buis <rwlbuis at gmail.com>  2012-05-04 04:49:44 PST ---
(From update of attachment 140169)
View in context: https://bugs.webkit.org/attachment.cgi?id=140169&action=review

Can be cleaned up some more.

> Source/WebCore/platform/network/blackberry/AutofillBackingStore.cpp:24
> +#include "NotImplemented.h"

Can be removed?

> Source/WebCore/platform/network/blackberry/AutofillBackingStore.cpp:163
> +    int numOfRow = m_hasStatement->getColumnInt(0);

Do you mean numberOfRows here or rowNumber? 
Better not abbreviate.

> Source/WebCore/platform/network/blackberry/AutofillBackingStore.cpp:170
> +    return false;

You can combine these into one return statement.

> Source/WebCore/platform/network/blackberry/AutofillBackingStore.h:23
> +#include <wtf/Vector.h>

Does not seem like we need this include here.

> Source/WebCore/platform/network/blackberry/AutofillBackingStore.h:40
> +    bool has(const String& name, const String& value);

has is an unclear name for a function. How about contains?

> Source/WebCore/platform/network/blackberry/AutofillBackingStore.h:41
> +

Please check if any of the functions are const.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list