[Webkit-unassigned] [Bug 23750] Cannot resize frames because frameborder=0

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 2 01:36:11 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=23750


Kenneth Rohde Christiansen <kenneth at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #139434|review?                     |review-
               Flag|                            |




--- Comment #5 from Kenneth Rohde Christiansen <kenneth at webkit.org>  2012-05-02 01:36:11 PST ---
(From update of attachment 139434)
View in context: https://bugs.webkit.org/attachment.cgi?id=139434&action=review

> Source/WebCore/ChangeLog:9
> +     

Any link to what the spec says about this? I mean there must be a reason for the original code

> Source/WebCore/rendering/RenderFrameSet.cpp:671
> -    if (split == noSplit || !axis.m_allowBorder[split] || axis.m_preventResize[split]) {
> +    if (split == noSplit || axis.m_preventResize[split]) {

Please make sure that this is not breaking frame flattening in any way

> LayoutTests/fast/frames/frames-with-frameborder-zero-can-be-resized.html:8
> +            if (window.layoutTestController)
> +                layoutTestController.dumpAsText();
> +
> +            function log(frame, success, isWidth, size) {
> +              if (window.layoutTestController) {

inconsistent indentation

> LayoutTests/fast/frames/frames-with-frameborder-zero-can-be-resized.html:9
> +                alert(frame.name + ' resized correctly = ' + (success ? 'true' : 'false'));

We normally write PASSED or FAILED, but true, false. Please check how other tests are made

> LayoutTests/fast/frames/frames-with-frameborder-zero-can-be-resized.html:24
> +                if (!window.layoutTestController)

You have these tests all over. Why not rename init() to run() or so and add this test as the first thing.

> LayoutTests/fast/frames/frames-with-frameborder-zero-can-be-resized.html:30
> +                    //Move the One/* vertical resizer ten pixels west...

Please add a space after // and just one punctuation mark at the end

> LayoutTests/fast/frames/frames-with-frameborder-zero-can-be-resized.html:49
> +            function checkSuccess() {
> +                    log(One, One.frameElement.width == 100, true, 100)
> +                    log(Two, Two.frameElement.height == 80, false, 80)

very inconsistent indentation again

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list