[Webkit-unassigned] [Bug 82307] [WebSocket]Browser must fail connection if Sec-WebSocket-Protocol mismatched.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Mar 28 19:14:39 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=82307





--- Comment #14 from Kent Tamura <tkent at chromium.org>  2012-03-28 19:14:39 PST ---
(From update of attachment 134479)
View in context: https://bugs.webkit.org/attachment.cgi?id=134479&action=review

> Source/WebCore/Modules/websockets/WebSocket.cpp:154
> +static const char* webSocketSubProtocolSeperator = ", ";
> +
> +const char* WebSocket::getSubProtocolSeperator()
> +{
> +    return webSocketSubProtocolSeperator;

We don't need webSocketSubProtocolSeparator const variable.
return ", "; is ok.

We don't add "get" prefix for such function.  This should be named as subProtocolSeparator().

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list