[Webkit-unassigned] [Bug 75553] [GTK][WK2] Initial FullScreen support

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Mar 14 01:43:18 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=75553





--- Comment #35 from Carlos Garcia Campos <cgarcia at igalia.com>  2012-03-14 01:43:18 PST ---
(From update of attachment 131322)
View in context: https://bugs.webkit.org/attachment.cgi?id=131322&action=review

I think moving the FullScreenWindowController to WebKitWebViewBase would make the things clearer and easier, specially to implement the signals in WebKitWebView

> Source/WebKit2/UIProcess/gtk/FullScreenWindowController.cpp:36
> +    : m_webViewBase(0)

I would call this webView, for wk2 internal code there's just a view.

> Source/WebKit2/UIProcess/gtk/FullScreenWindowController.cpp:97
> +    m_webViewBase = 0;

Why clearing the view after exiting fullscreen? Isn't this object owned by the view indeed?

> Source/WebKit2/UIProcess/gtk/FullScreenWindowController.cpp:108
> +#endif

I still think this object is not needed, the impl could be part of WebKitWebViewBase, so that the fullscreen manager proxy just need to call webkitWebViewBaseEnterFullscreen/ExitFullscreen(). I know the mac port has a WKFullScreenWindowController, but the WK prefix makes me think it's actually part of the API layer somehow. We could use a private object in our API layer that could be used by WebKitWebView to implement the fullscreen signals.

> Source/WebKit2/UIProcess/gtk/WebFullScreenManagerProxyGtk.cpp:50
> +    WebKitWebViewBase* webViewBase = WEBKIT_WEB_VIEW_BASE(m_webView);
> +    FullScreenWindowController& controller = webkitWebViewBaseFullscreenWindowController(webViewBase);
> +    controller.setWebViewBase(webViewBase);

It's a bit weird that you ask the view for the controller and then you need to set the view of the controller. That controller is stack allocated in the view, isn't it associated to that view forever?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list