[Webkit-unassigned] [Bug 80713] Add new methods to FrameLoaderClient so different WebKit ports can customize the ResourceRequest when it is created.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Mar 12 13:02:06 PDT 2012


--- Comment #28 from Lyon Chen <liachen at rim.com>  2012-03-12 13:02:05 PST ---
(In reply to comment #26)
> I don't like the name of the two new methods, though.  First, they can be used to update existing fields as well as add new fields, so "addExtraFields" doesn't seem right.  Second, I think we should have just one new method, with an enum parameter saying whether it's a main resource of subresource request.  I suggest calling it "customizeRequest", or to be more explicit about timing, "customizeRequestBeforePolicyCheck".

Yeah, the method name is not well chosen and I am more than willing to change them to more proper name.

But I think the resource type for subresource load is needed to better understand what this request for, and for better customization.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list