[Webkit-unassigned] [Bug 80835] New: Style checker complains about naming parameter with default values

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Mar 12 07:26:16 PDT 2012


           Summary: Style checker complains about naming parameter with
                    default values
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Tools / Tests
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: tonikitoo at webkit.org

It happened in https://bugs.webkit.org/show_bug.cgi?id=79611#c4

Code looks like this:

- void calculateScrollbarModesForLayout(ScrollbarMode& hMode, ScrollbarMode& vMode);
+ void calculateScrollbarModesForLayout(ScrollbarMode& hMode, ScrollbarMode& vMode, ScrollbarModesCalculationStrategy strategy = AnyRule);

and the code style checker complained that 'strategy' added not value:

>> Source/WebCore/page/FrameView.h:283:  The parameter name "strategy" adds no information, so it should be removed.  [readability/parameter_name] [5]

However it is needed, given the default value.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list