[Webkit-unassigned] [Bug 80779] All DFG nodes should have a mutable set of flags

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Mar 11 23:14:14 PDT 2012


--- Comment #9 from Filip Pizlo <fpizlo at apple.com>  2012-03-11 23:14:13 PST ---
(In reply to comment #8)
> There is an awful lot of static_cast<NodeType>(node.op) in this patch.  It would be really good to make op private (& probably should be called m_op), and change op() to be an accessor function returning a NodeType.  Would probably be nice to do the same for flags.  What do you think?

I'm with you!

I had avoided doing that because I had already racked up 50kb of changes.  I feared that privatizing Node::op will introduce even more changes.

I want to make that change and would be happy to do it in this patch.  But how would you feel about that being a follow-on patch?

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list