[Webkit-unassigned] [Bug 48459] Glyphs in vertical text tests are rotated 90 degrees clockwise on Windows

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Mar 4 02:20:46 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=48459





--- Comment #45 from WebKit Review Bot <webkit.review.bot at gmail.com>  2012-03-04 02:20:45 PST ---
Attachment 130022 did not pass style-queue:

Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.h:20:  The parameter name "fontData" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.h:21:  The parameter name "fontData" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.h:25:  The parameter name "glyph" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.h:26:  The parameter name "glyphPage" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:317:  Should have a space between // and comment  [whitespace/comments] [4]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:322:  Should have a space between // and comment  [whitespace/comments] [4]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:324:  Should have a space between // and comment  [whitespace/comments] [4]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:340:  Should have a space between // and comment  [whitespace/comments] [4]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:341:  Should have a space between // and comment  [whitespace/comments] [4]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:342:  Should have a space between // and comment  [whitespace/comments] [4]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:343:  Should have a space between // and comment  [whitespace/comments] [4]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:344:  Should have a space between // and comment  [whitespace/comments] [4]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:345:  Should have a space between // and comment  [whitespace/comments] [4]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:346:  Should have a space between // and comment  [whitespace/comments] [4]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:347:  Should have a space between // and comment  [whitespace/comments] [4]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:352:  Should have a space between // and comment  [whitespace/comments] [4]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:355:  Should have a space between // and comment  [whitespace/comments] [4]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:356:  Should have a space between // and comment  [whitespace/comments] [4]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:357:  Should have a space between // and comment  [whitespace/comments] [4]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:358:  Should have a space between // and comment  [whitespace/comments] [4]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:362:  Should have a space between // and comment  [whitespace/comments] [4]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:363:  Should have a space between // and comment  [whitespace/comments] [4]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:450:  Tab found; better to use spaces  [whitespace/tab] [1]
Source/WebCore/platform/graphics/win/FontCGWin.cpp:453:  Tab found; better to use spaces  [whitespace/tab] [1]
Source/WebCore/platform/graphics/FontPlatformData.h:192:  The parameter name "orientation" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/platform/graphics/FontPlatformData.h:194:  The parameter name "orientation" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/platform/graphics/win/SimpleFontDataWin.cpp:288:  Use 0 instead of NULL.  [readability/null] [5]
Source/WebCore/platform/graphics/win/SimpleFontDataWin.cpp:292:  One line control clauses should not use braces.  [whitespace/braces] [4]
Source/WebCore/platform/graphics/SimpleFontData.h:212:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/platform/graphics/SimpleFontData.h:213:  The parameter name "size" adds no information, so it should Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/WebCore.vcproj/WebCore.vcpr..." exit_code: 1
be removed.  [readability/parameter_name] [5]
Source/WebCore/platform/graphics/win/GlyphPageTreeNodeCGWin.cpp:59:  One line control clauses should not use braces.  [whitespace/braces] [4]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.cpp:38:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.cpp:41:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.cpp:47:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.cpp:66:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.cpp:168:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.cpp:180:  Missing space before {  [whitespace/braces] [5]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.cpp:185:  Missing space before {  [whitespace/braces] [5]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.cpp:191:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.cpp:203:  One line control clauses should not use braces.  [whitespace/braces] [4]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.cpp:233:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.cpp:292:  One line control clauses should not use braces.  [whitespace/braces] [4]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.cpp:334:  One line control clauses should not use braces.  [whitespace/braces] [4]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.cpp:433:  One line control clauses should not use braces.  [whitespace/braces] [4]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.cpp:458:  One line control clauses should not use braces.  [whitespace/braces] [4]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.cpp:484:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.cpp:506:  Tab found; better to use spaces  [whitespace/tab] [1]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.cpp:509:  Tab found; better to use spaces  [whitespace/tab] [1]
Source/WebCore/platform/graphics/opentype/OpenTypeVerticalData.cpp:510:  Tab found; better to use spaces  [whitespace/tab] [1]
Total errors found: 49 in 15 files


If any of these errors are false positives, please file a bug against check-webkit-style.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list