[Webkit-unassigned] [Bug 62698] Support for Battery Status API

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Mar 1 23:20:56 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=62698





--- Comment #41 from Kihong Kwon <kihong.kwon at samsung.com>  2012-03-01 23:20:54 PST ---
(From update of attachment 129806)
View in context: https://bugs.webkit.org/attachment.cgi?id=129806&action=review

Thank you for your kind review.

>> Source/WebCore/Modules/battery/BatteryStatus.cpp:38
>> +
> 
> Unneeded line.

OK.

>> Source/WebCore/dom/Document.cpp:1960
>> +        return;
> 
> Need to add an empty line.

You are right.

>> Source/WebCore/dom/EventNames.h:61
>> +    macro(dischargingtimechange) \
> 
> Alphabetical sorting nit.

OK.

>> Source/WebKit/efl/ewk/ewk_view.cpp:780
>> +    smartData->_priv = _ewk_view_priv_new(smartData);
> 
> Why do you change location of private data creation ?

The smartData->api have to set before calling _ewk_view_priv_new().
Because use_mock which is in the api is used in the _ewk_view_priv_new(),

>> Source/WebKit/efl/ewk/ewk_view.h:125
>> +    Eina_Bool useMock;
> 
> We are using efl coding style in public header.

OK. I will be fix.

>> Source/WebKit/efl/ewk/ewk_view.h:2368
>> +EAPI void ewk_view_dump_render_tree_mode_enable(Evas_Object* ewkView, Eina_Bool flag);
> 
> variable name is wrong. Please read WebKit EFL coding style first.
> http://trac.webkit.org/wiki/EFLWebKitCodingStyle

OK.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list