[Webkit-unassigned] [Bug 80015] New: Make the tiling code slightly smarter

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Mar 1 01:29:15 PST 2012


           Summary: Make the tiling code slightly smarter
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: WebKit Qt
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: kenneth at webkit.org
                CC: hausmann at webkit.org

Avoid doing the same tranformations all over in each call to tileRectForCoordinate.

Do not resize tiles and then drop them because they are not out of the keep rect; instead drop before resizing.

Rename dropTilesOutsideRect to setKeepRect as it now stored the keep rect. This is used to avoid unneeded iteration of all tiles for invalidates outside the keep rect.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list