[Webkit-unassigned] [Bug 90277] Web Inspector: added DecodeImage and ResizeImage events to TimelineAgent

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 29 07:22:22 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=90277


Pavel Feldman <pfeldman at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #150164|review?                     |review-
               Flag|                            |




--- Comment #7 from Pavel Feldman <pfeldman at chromium.org>  2012-06-29 07:22:20 PST ---
(From update of attachment 150164)
View in context: https://bugs.webkit.org/attachment.cgi?id=150164&action=review

> Source/WebCore/ChangeLog:8
> +        * inspector/InspectorInstrumentation.h:

Please explain what happens and why above this line.

> Source/WebCore/inspector/InspectorInstrumentation.h:843
> +    if (!hasFrontends())

Please use FAST_RETURN_IF_NO_FRONTENDS macro

> Source/WebCore/inspector/InspectorInstrumentation.h:845
> +    if (InspectorTimelineAgent::instance())

You can not include InspectorTimelineAgent.h in instrumentation, so this would not work.

>> Source/WebCore/inspector/InspectorInstrumentation.h:846
>> +        InspectorTimelineAgent::instance()->willDecodeImage(rect);
> 
> Can we make these instrumentation methods static? This will also let us keep instance() private.

You need to call willDecodeImagImpl on the instrumentation instance here.

> Source/WebCore/inspector/TimelineRecordFactory.cpp:184
> +    data->setNumber("x", rect.x());

Please rename to createImageData and use in both cases.

> Source/WebCore/inspector/front-end/TimelineModel.js:53
> +    DecodeImage: "DecodeImage",

This will make the tests fail, you need to update expectations.

> Source/WebCore/inspector/front-end/TimelinePanel.js:133
> +    this._presentationModel.addFilter(new WebInspector.TimelineCategoryFilter());

You should not mix style changes with semantics changes.

> Source/WebCore/inspector/front-end/TimelinePresentationModel.js:76
> +    recordStyles[recordTypes.DecodeImage] = { title: WebInspector.UIString("Decode Image"), category: categories["painting"] };

New strings should go to the English.lproj/localizedStrings.js as well.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list