[Webkit-unassigned] [Bug 89197] [Chromium] Implements DeviceMotion

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 21 05:31:11 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=89197





--- Comment #13 from Hans Wennborg <hans at chromium.org>  2012-06-21 05:31:10 PST ---
(From update of attachment 148560)
Would any of the API reviewrs like to take a look?


I only have a couple of nits.


View in context: https://bugs.webkit.org/attachment.cgi?id=148560&action=review

> Source/WebKit/chromium/public/WebDeviceMotionData.h:150
> +    WebDeviceMotionData& operator=(const WebCore::DeviceMotionData*);

Hmm, I wonder if the two functions above are actually ever used or just there for "symmetry" reasons.
I don't know if we ever create a WebDevicemotionData from a DeviceMotionData; i suspect we only do it the other way around.
If we don't need them, maybe we should delete them because the definitions aren't too pretty.

> LayoutTests/ChangeLog:9
> +        Each tests corresponds to a similar existing test for DeviceOrientation, since they are part of the same spec and work very similarly.

s/Each tests/Each test/

> LayoutTests/fast/dom/DeviceMotion/multiple-frames.html:6
> +<script src="script-tests/multiple-frames.js"></script>

i don't know what the current WebKit policy is on this, maybe the other reviewers can comment, but if we could just put the test script in the .html file, that would be easier

> LayoutTests/fast/dom/DeviceMotion/script-tests/add-listener-from-callback.js:17
> +if (window.layoutTestController) {

there's an effort underway to rename layoutTestController to testRunner. Currently, both names work, but any new code should ideally use testRunner.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list