[Webkit-unassigned] [Bug 89366] FastMalloc.cpp needs to be reordered before padding bug can be fixed

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 20 10:13:13 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=89366





--- Comment #7 from WebKit Review Bot <webkit.review.bot at gmail.com>  2012-06-20 10:13:12 PST ---
Attachment 148591 did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WTF/ChangeLog', u'Source/WTF/wtf/Fa..." exit_code: 1
Source/WTF/wtf/FastMalloc.cpp:574:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WTF/wtf/FastMalloc.cpp:588:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WTF/wtf/FastMalloc.cpp:4241:  std::bad_alloc is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WTF/wtf/FastMalloc.cpp:4392:  __libc_malloc is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WTF/wtf/FastMalloc.cpp:4393:  __libc_free is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WTF/wtf/FastMalloc.cpp:4394:  __libc_realloc is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WTF/wtf/FastMalloc.cpp:4395:  __libc_calloc is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WTF/wtf/FastMalloc.cpp:4396:  __libc_cfree is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WTF/wtf/FastMalloc.cpp:4397:  __libc_memalign is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WTF/wtf/FastMalloc.cpp:4398:  __libc_valloc is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WTF/wtf/FastMalloc.cpp:4399:  __libc_pvalloc is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WTF/wtf/FastMalloc.cpp:4400:  __posix_memalign is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WTF/wtf/FastMalloc.cpp:4404:  __libc_malloc is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WTF/wtf/FastMalloc.cpp:4405:  __libc_free is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WTF/wtf/FastMalloc.cpp:4406:  __libc_realloc is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WTF/wtf/FastMalloc.cpp:4407:  __libc_calloc is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WTF/wtf/FastMalloc.cpp:4408:  __libc_cfree is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WTF/wtf/FastMalloc.cpp:4409:  __libc_memalign is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WTF/wtf/FastMalloc.cpp:4410:  __libc_valloc is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WTF/wtf/FastMalloc.cpp:4411:  __libc_pvalloc is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WTF/wtf/FastMalloc.cpp:4412:  __posix_memalign is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 21 in 2 files


If any of these errors are false positives, please file a bug against check-webkit-style.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list