[Webkit-unassigned] [Bug 88663] Renamed DeviceOrientation to DeviceOrientationData

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Jun 9 12:28:12 PDT 2012


Hans Wennborg <hans at chromium.org> changed:

           What    |Removed                     |Added
                 CC|                            |hans at chromium.org

--- Comment #9 from Hans Wennborg <hans at chromium.org>  2012-06-09 12:28:10 PST ---
(In reply to comment #7)
> What's the reason for this change? In OOP, classes encapsulate both data and behaviors, so there needs to be a specific reason to introduce a "Data" class.

(In reply to comment #8)
> (From update of attachment 146589 [details])
> I have the same question as Alexey.  This patch doesn't explain why we should make this change.  (I don't have an opinion about whether we should make the change because I don't understand the motiviation.)

The motivation is to match DeviceMotionData, which we think has a better name.

We'll update the description (and make the EWS bots green) next week.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list