[Webkit-unassigned] [Bug 68509] [EFL] Implementation of Unit Tests framework for the WebKit-Efl port

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 6 06:42:17 PDT 2012


--- Comment #31 from Thiago Marcos P. Santos <tmpsantos at gmail.com>  2012-06-06 06:42:16 PST ---
> > What about test_ewk_settings.cpp, test_ewk_view.cpp, etc.?
> I also thought about this, but on the other way, it might cause some mess. It wouldn't be readable. What do you think ?. One function can have couple of test cases and it's good to have them in one file for further debugging and understanding.
> What do you think, if we have separate folders for each test's category under WebKit/efl/tests/. Example ./WebKit/efl/tests/ewk_view. All the test related to ewk_view API would be placed there.

I like the idea of using a prefix because it is easier for the test runner to list what has to be executed.

I'm fine on using: prefix_realm.cpp (test_settings.cpp, test_localization.cpp, test_webview.cpp, test_view_single.cpp, test_view_tiled.cpp, etc). But I don't think that a separated folder is necessary since it is likely that most of the folders will have just one file.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list