[Webkit-unassigned] [Bug 77899] IETC: FileList.item(-1) should return null instead of raising

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Jun 3 21:26:39 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=77899





--- Comment #16 from Li Yin <li.yin at intel.com>  2012-06-03 21:26:38 PST ---
(In reply to comment #14)
> (From update of attachment 145312 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=145312&action=review
> 
> > LayoutTests/fast/files/file-list-test.html:13
> > +var caseArray = [["resources/UTF8.txt", "resources/UTF8-2.txt"], []];
> 
> Can we add a comment 'caseArray must end with an empty item' or something like that since the test code seems to rely on the assumption?

Using the expression "if (caseArray[globalIndex]].length == 0)" as you refered, It will not be a must that array ends with an empty.

> 
> > LayoutTests/fast/files/file-list-test.html:14
> > +var globalIndex = 0;
> 
> naming-nit: How about naming it caseIndex to indicate it is the index of caseArray?
> 
> > LayoutTests/fast/files/file-list-test.html:18
> > +    if (globalIndex == 1) {
> 
> if (caseArray[globalIndex]].length == 0)
> 
> might make this code more generic?
>

Done. 

> > LayoutTests/fast/files/file-list-test.html:19
> > +        testFailed("onInputFileChange was called.");
> 
> "... was called for an empty file list" ?

Done.

Thanks.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list