[Webkit-unassigned] [Bug 89840] [WK2][EFL] Implement accelerated compositing on WK2 Efl port

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 30 23:57:54 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=89840





--- Comment #30 from YoungTaeck Song <youngtaeck.song at samsung.com>  2012-07-30 23:57:53 PST ---
(In reply to comment #29)
> (From update of attachment 155194 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=155194&action=review
> 
> > Source/WebKit2/UIProcess/API/efl/EflViewportHandler.cpp:83
> > +    if (m_visibleContentRect.x() > contentsSize.width() - m_visibleContentRect.width())
> > +        m_visibleContentRect.setX(contentsSize.width() - m_visibleContentRect.width());
> > +    if (m_visibleContentRect.x() < 0)
> > +        m_visibleContentRect.setX(0);
> > +    if (m_visibleContentRect.y() > contentsSize.height() - m_visibleContentRect.height())
> > +        m_visibleContentRect.setY(contentsSize.height() - m_visibleContentRect.height());
> > +    if (m_visibleContentRect.y() < 0)
> > +        m_visibleContentRect.setY(0);
> 
> This code is hard to read. Is this an intersect? Or is this a copy from some Qt code?
> If it's an intersection, please use IntRect::intersect. If not, please add some comments to clarify.

Thanks for kind review.
And I'm very sorry too late.

This code is for moving visibleContentRect inside content rect when visibleContentRect is out of the content rect.
Efl's webview doesn't know contents size, so We have to use this code.

I'll use more clear comments at next patch.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list