[Webkit-unassigned] [Bug 90375] Parallel image decoders

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 30 18:56:11 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=90375





--- Comment #46 from Huang Dongsung <luxtella at company100.net>  2012-07-30 18:56:10 PST ---
(In reply to comment #45)
> 
> My goal of this patch is to remove currentFrameHasAlpha() and frameHasAlphaAtIndex() from Image. This is a tricky task but I think is achievable. Doing so would leave most metadata functions protected / internal to BitmapImage and I shall have better answers to your questions.
> 

I think making most metadata functions protected / internal to BitmapImage is the most appropriate solution.

I also think we should remove the explicit metadata query methods when implementing parallel image decoders.
There may be two approaches to do this.

1. Remove all metadata query methods and rename BitmapImage::nativeImageForCurrentFrame to BitmapImage::currnetFrame, and make the function return the current frame struct.
2. Remove all metadata query methods and call platform specific metadata query functions using nativeImagePtr.

Both causes a big refactoring. So, I postponed this refactoring.

I appreciate you are doing this refactoring.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list