[Webkit-unassigned] [Bug 92342] Web Inspector [JSC]: Support multi instance for PageScriptDebugServer of JSC

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jul 27 03:07:52 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=92342





--- Comment #7 from Peter Wang <peter.wang at torchmobile.com.cn>  2012-07-27 03:07:53 PST ---
(In reply to comment #6)
> (From update of attachment 154609 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=154609&action=review
> 
> > Source/WebCore/bindings/js/PageScriptDebugServer.cpp:68
> > +    if (!page)
> 
> How can it happen?
For InspectorProfilerAgent, I planned just changed the behavior of InspectorDebugAgent firstly to be on safe side. But it seems confused, I'll correct it in new patch.  
> > Source/WebCore/bindings/js/PageScriptDebugServer.cpp:86
> > +    m_pageDebugServerMap.add(page, serverForPage);
> 
> Pleas move this line into PageScriptDebugServer constructor.
ok. Thx, it's better.
> > Source/WebCore/bindings/js/PageScriptDebugServer.cpp:198
> > +    deleteInstance(page);
> 
> I'd replace this with delete this; and get rid of PageScriptDebugServer::deleteInstance
ok. Thx, it's better.
> > Source/WebCore/bindings/v8/PageScriptDebugServer.cpp:67
> > +PageScriptDebugServer& PageScriptDebugServer::shared(Page*)
> 
> Please rename this method to something like forPage as now there is no shared instance.
> 
ok.
> > Source/WebCore/inspector/PageDebuggerAgent.cpp:72
> > +    if (PageScriptDebugServer::isMultiInstance())
> 
> No need in this check just ignore the Page* argument in case of v8 and delete isMultiInstance.
ok.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list