[Webkit-unassigned] [Bug 91630] Web Inspector: Incorrect XHR responses when two async xhrs are sent synchronously

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 24 08:24:52 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=91630


Vsevolod Vlasov <vsevik at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #153523|review?                     |review-
               Flag|                            |




--- Comment #12 from Vsevolod Vlasov <vsevik at chromium.org>  2012-07-24 08:24:54 PST ---
(From update of attachment 153523)
View in context: https://bugs.webkit.org/attachment.cgi?id=153523&action=review

Please fix style nits and add ChangeLogs.

> Source/WebCore/inspector/InspectorInstrumentation.cpp:678
> +    InspectorInstrumentation::didReceiveResourceResponse(cookie, identifier, loader, r, 0);

You don't need 0 here because you resourceLoader parameter has default value.

> Source/WebCore/inspector/InspectorResourceAgent.cpp:246
> +        CachedResource* cachedResource = (resourceLoader && resourceLoader->isSubresourceLoader()) ? reinterpret_cast<SubresourceLoader*>(resourceLoader)->cachedResource() :  InspectorPageAgent::cachedResource(loader->frame(), response.url());

You should use static_cast instead.
Also this line is too hard to read, please use *if* instead of ?:
Also please always fallback to InspectorPageAgent::cachedResource.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list