[Webkit-unassigned] [Bug 92069] IndexedDB: IDBTransaction::abort() should throw DOMException if "finished"

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 24 08:06:49 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=92069


Joshua Bell <jsbell at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |ASSIGNED
     Ever Confirmed|0                           |1




--- Comment #8 from Joshua Bell <jsbell at chromium.org>  2012-07-24 08:06:53 PST ---
(In reply to comment #3)
> > We do not want two abort() methods if possible. How about just changing the current 'void abort()' to 'void abort(ExceptionCode& ec)'?
> 
> abort() also needs to be called internally without throw exception, so I add another abort(ExceptionCode& ec) for external calling. If I just change abort() to abort(ExceptionCode& ec), all the points of call abort() need to be modified.

We could name the new IDL method implementation something else (e.g. abortMethod ? I can't think of anything good right now) and add an IDL attribute like we do for methods where there's a C++ keyword collision, e.g. for IDBCursor.continue:

 [ImplementedAs=continueFunction] void continue( ... ) raises ( ... );

I'd also be fine with renaming the "internal" abort something else. (We have a foo/fooInternal naming convention, but that's usually for private static impls of callbacks.)

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list