[Webkit-unassigned] [Bug 91731] [EFL][WK2][WTR] Implement EventSenderProxy

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jul 20 00:18:50 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=91731





--- Comment #19 from Gyuyoung Kim <gyuyoung.kim at samsung.com>  2012-07-20 00:18:51 PST ---
(From update of attachment 153424)
View in context: https://bugs.webkit.org/attachment.cgi?id=153424&action=review

> Tools/WebKitTestRunner/efl/EventSenderProxyEfl.cpp:48
> +    WTREventTypeNone,

I think it is better to initialize with default value in order to recognize enum type value more easily.

> Tools/WebKitTestRunner/efl/EventSenderProxyEfl.cpp:65
> +    EvasMouseButtonNone,

ditto.

> Tools/WebKitTestRunner/efl/EventSenderProxyEfl.cpp:166
> +        evas_event_feed_mouse_wheel(evas, 1, -10, 0, 0);

Why don't you make constant variable for scroll direction ? In this case, it looks -10 can be replaced by SCROLL_LEFT. This is more readable.

> Tools/WebKitTestRunner/efl/EventSenderProxyEfl.cpp:298
> +void EventSenderProxy::dispatchEvent(const WTREvent& wtrEvent)

It seems to me *wtr* prefix is not unneeded in *wtrEvent*.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list