[Webkit-unassigned] [Bug 91766] didFirstVisuallyNonEmptyLayout() callback not fired when about:blank page is modified

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jul 19 13:02:27 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=91766





--- Comment #3 from Beth Dakin <bdakin at apple.com>  2012-07-19 13:02:26 PST ---
This is a very strange and poorly-named API. We have been considering re-naming it actually.

(In reply to comment #1)
> We need to understand the intent of this callback.  It's possible it's just part of the loading lifecycle and should always fire sometime after Commit and before DOMContentLoaded or Loaded.
> 
> > w.document.innerHTML += "foo"
> 

See these lines in FrameView::performPostLayoutTasks():

// Ensure that we always send this eventually.
if (!m_frame->document()->parsing() && m_frame->loader()->stateMachine()->committedFirstRealDocumentLoad())
            m_isVisuallyNonEmpty = true;

So yes, the assumption right now is that it should always fire when the above criteria are met.

> It's not clear to me whether this should fire didFirstVisuallyNonEmptyLayout().  In this case, w might finish loading entirely before this line of code executes.
> 
> > the callback is not fired at all when using window.open(slow_url
> 
> That definitely sounds like a bug.  It should fire at some deterministic time in the lifecycle.

This is probably a bug.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list