[Webkit-unassigned] [Bug 91632] Web Inspector: extracting HighlightInfo from HighlightData in DOMNodeHighlighter

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jul 19 03:27:55 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=91632





--- Comment #2 from Andrey Kosyakov <caseq at chromium.org>  2012-07-19 03:27:54 PST ---
(From update of attachment 153043)
View in context: https://bugs.webkit.org/attachment.cgi?id=153043&action=review

> Source/WebCore/inspector/DOMNodeHighlighter.cpp:538
> +    if (highlightInfo) {

So we're clearing highlight when passed a null highlightInfo. Can we instead have a separate method for that?

> Source/WebCore/inspector/DOMNodeHighlighter.cpp:551
> +        m_highlightData->highlightInfo = adoptPtr(new HighlightInfo(*highlightInfo));

Does highlightInfo member have to be a pointer?

> Source/WebCore/inspector/DOMNodeHighlighter.h:51
> +struct HighlightInfo {

HighlightInfo is too generic -- can we find a better name? HighlightConfig sounds like a slightly better match.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list