[Webkit-unassigned] [Bug 91196] Web Inspector: refactor InspectorController::connectFrontend() to accept InspectorFrontendChannel.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 16 09:53:09 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=91196





--- Comment #14 from Pavel Feldman <pfeldman at chromium.org>  2012-07-16 09:53:07 PST ---
(From update of attachment 152510)
View in context: https://bugs.webkit.org/attachment.cgi?id=152510&action=review

So far looks good!

> Source/WebCore/inspector/InspectorController.cpp:263
> +        m_inspectorFrontendChannel = m_inspectorClient->openInspectorFrontend(this);

The call below will do this for you, store it in a temporary variable for now.

> Source/WebCore/inspector/InspectorController.cpp:279
> +    connectFrontend(m_inspectorFrontendChannel);

I would rename and extend "restoreInspectorStateFromCookie" to

InspectorController::reconnectFrontend(InspectorFrontendChannel* channel, const String& inspectorStateCookie)

> Source/WebCore/loader/EmptyClients.h:565
> +class EmptyInspectorClient : public InspectorClient, public InspectorFrontendChannel {

This should not change, you should instead remove sendMessageToFrontend from it.

> Source/WebKit/win/WebCoreSupport/WebInspectorClient.cpp:174
> +        return 0;

We should make sure call site is ready to accept 0 (it should not crash).

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list