[Webkit-unassigned] [Bug 91310] Add test cases in Functional.cpp related to handling wrapping/unwrapping RefPtr and PassRefPtr.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jul 13 22:51:05 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=91310





--- Comment #4 from Kwang Yul Seo <skyul at company100.net>  2012-07-13 22:51:05 PST ---
(From update of attachment 152406)
View in context: https://bugs.webkit.org/attachment.cgi?id=152406&action=review

> Tools/TestWebKitAPI/Tests/WTF/Functional.cpp:182
> +template<typename T> static int multiplyNumberByTwo(PassRefPtr<T> pass)

If the argument is transferred to a RefPtr at the start of the function, the argument should be named with a "prp" prefix.

Refer to http://www.webkit.org/coding/RefPtr.html for the naming guideline.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list