[Webkit-unassigned] [Bug 89751] Change RenderTable sections' iterations for removing anti-patterns and using helper functions.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jul 12 14:58:53 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=89751


Julien Chaffraix <jchaffraix at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #149505|review?, commit-queue?      |review+, commit-queue-
               Flag|                            |




--- Comment #8 from Julien Chaffraix <jchaffraix at webkit.org>  2012-07-12 14:58:52 PST ---
(From update of attachment 149505)
View in context: https://bugs.webkit.org/attachment.cgi?id=149505&action=review

r=me without the splitColumns part.

> Source/WebCore/ChangeLog:3
> +        Change RenderTable sections' iterations for removing anti-patterns and using helper functions.

A better name: Refactor RenderTable to use the section's iteration functions

> Source/WebCore/ChangeLog:11
> +        No new tests required for this change.

Usually you justify why. Here it is because you don't expect any change in behavior.

> Source/WebCore/rendering/RenderTable.cpp:683
> +    for (RenderTableSection* section = topSection(); section; section = sectionBelow(section)) {

You are right nothing guarantees us not to need a section recalc here.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list