[Webkit-unassigned] [Bug 89000] [CSS Regions] Fix the lifecycle for the flow objects and their renderers

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 11 16:25:47 PDT 2012


--- Comment #36 from Eric Seidel <eric at webkit.org>  2012-07-11 16:25:46 PST ---
(From update of attachment 151436)
View in context: https://bugs.webkit.org/attachment.cgi?id=151436&action=review

So there will always be exactly one NamedFlow per name, likewise exactly one RenderNamedFlow per name.  And these will be associated via bi-directional weak pointers, correct?

> Source/WebCore/dom/WebKitNamedFlow.h:63
> +    FlowState getFlowState() const { return m_state; }

This should just be flowState(), no "get".

> Source/WebCore/dom/WebKitNamedFlow.h:64
> +    void switchFlowState() { m_state = m_state == FlowStateNull ? FlowStateCreated : FlowStateNull; }

Please make this setFlowState(), then callers will be more explicit (and hopefully more readable).  i don't think you ever need this "switch" behavior.  Callers always know what state they want the flow in.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list