[Webkit-unassigned] [Bug 90758] New: Refactoring metadata of BitmapImage.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 9 00:14:22 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=90758

           Summary: Refactoring metadata of BitmapImage.
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: UNCONFIRMED
          Severity: Normal
          Priority: P2
         Component: Images
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: luxtella at company100.net


There is no precise definition of FrameData's metadata. So I assume the metadata as a combination of m_orientation, m_duration, and m_hasAlpha. This definition works fine because currently there is no method that uses m_haveMetadata on its purpose.

This patch contains two changes:

1. Remove FrameData::m_haveMetadata for readability.
Only BitmapImage::dataChanged uses m_haveMetadata in order to check whether the frame is cleared or not, and it is enough to check whether FrameData::m_frame is 0.

2. Don't decode again if metadata exist.
If the indexed frame was once decoded completely and cleared by destroyDecodedData(), We don't need to decode again in order to know metadata because destroyDecodedData() does not reset the metadata. See destroyDecodedData().

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list