[Webkit-unassigned] [Bug 77381] New: The spec renamed addTrack() to addTextTrack()

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 30 16:16:32 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=77381

           Summary: The spec renamed addTrack() to addTextTrack()
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: UNCONFIRMED
          Severity: Normal
          Priority: P2
         Component: Media Elements
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: silviapf at chromium.org


The IDL of the tracks API in HTMLMediaElement has changed in the HTML spec:

===
third_party/WebKit/WebKitBuild/Release/DerivedSources/WebCore/WebCore/html/HTMLMediaElement.idl :

#if defined(ENABLE_VIDEO_TRACK) && ENABLE_VIDEO_TRACK
    [EnabledAtRuntime=webkitVideoTrack] TextTrack addTrack(in DOMString kind, in [Optional] DOMString label, in [Optional] DOMString language)
        raises (DOMException);
    readonly attribute [EnabledAtRuntime=webkitVideoTrack] TextTrackList textTracks;
#endif
===

===
http://www.whatwg.org/specs/web-apps/current-work/multipage/the-video-element.html#media-elements :

// tracks
  readonly attribute TextTrackList textTracks;
  TextTrack addTextTrack(DOMString kind, optional DOMString label, optional DOMString language);
===

Please rename the function from addTrack() to addTextTrack()

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list