[Webkit-unassigned] [Bug 76389] Form select option not de-selecting

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 30 12:10:41 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=76389





--- Comment #10 from Pablo Flouret <pablof at motorola.com>  2012-01-30 12:10:41 PST ---
(From update of attachment 124049)
View in context: https://bugs.webkit.org/attachment.cgi?id=124049&action=review

>>> Source/WebCore/html/HTMLSelectElement.cpp:771
>>> +        selectOption(m_multiple || size() > 1 ? -1 : nextSelectableListIndex(-1));
>> 
>> I think for clarity we tend to parenthesize the whole conditional even though rules of operator priority makes this correct anyway.
>> 
>> However, given the more complex expression, I would instead opt to just break this up into an "else if" and "else" clause, for readability and parallelism.
> 
> Should this be !usesMenuList()?

I think it makes sense, yeah.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list