[Webkit-unassigned] [Bug 76389] Form select option not de-selecting

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Jan 29 21:48:00 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=76389





--- Comment #7 from Jon Lee <jonlee at apple.com>  2012-01-29 21:47:59 PST ---
(From update of attachment 124049)
View in context: https://bugs.webkit.org/attachment.cgi?id=124049&action=review

> Source/WebCore/html/HTMLSelectElement.cpp:771
> +        selectOption(m_multiple || size() > 1 ? -1 : nextSelectableListIndex(-1));

I think for clarity we tend to parenthesize the whole conditional even though rules of operator priority makes this correct anyway.

However, given the more complex expression, I would instead opt to just break this up into an "else if" and "else" clause, for readability and parallelism.

> LayoutTests/ChangeLog:9
> +        * fast/forms/select-option-selecting.html: Added.

I've never quite understood where to place these tests-- I assume to keep the folder manageable we should be putting new tests in fast/forms/select/ instead? It looks like newer tests are being added there.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list