[Webkit-unassigned] [Bug 77070] All DFG helpers that may call out to arbitrary JS code must know where they were called from due to inlining and call stack walking
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Thu Jan 26 15:02:27 PST 2012
https://bugs.webkit.org/show_bug.cgi?id=77070
Geoffrey Garen <ggaren at apple.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #124067|review? |review+
Flag| |
--- Comment #12 from Geoffrey Garen <ggaren at apple.com> 2012-01-26 15:02:27 PST ---
(From update of attachment 124067)
View in context: https://bugs.webkit.org/attachment.cgi?id=124067&action=review
Need some Windows JavaScriptCore.def love:
3>JavaScriptCore.exp : error LNK2001: unresolved external symbol "public: class JSC::JSValue __thiscall JSC::Interpreter::retrieveCaller(class JSC::ExecState *,class JSC::JSFunction *)const " (?retrieveCaller at Interpreter@JSC@@QBE?AVJSValue at 2@PAVExecState at 2@PAVJSFunction at 2@@Z)
Need to double-check that we're actually passing this test:
fast/js/dfg-inline-arguments-use-from-all-the-places-broken.html -> unexpected text diff mismatch
> Source/JavaScriptCore/jit/JITStubs.h:287
> + inline bool returnAddressIsInCallTrampoline(ReturnAddressPtr returnAddress)
Small quibble: I don't think it's right to name this the "call trampoline", since it's used for entry to global code as well. I would call it "returnAddressIsInCtiTrampoline", to match the C function name.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list