[Webkit-unassigned] [Bug 76508] [Chromium] Random characters got rendered as empty boxes or with incorrect glyphs even when a font is present

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 18 23:34:06 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=76508





--- Comment #8 from Kazuhiro Inaba <kinaba at chromium.org>  2012-01-18 23:34:06 PST ---
(From update of attachment 123062)
View in context: https://bugs.webkit.org/attachment.cgi?id=123062&action=review

>> Source/WebCore/platform/graphics/chromium/GlyphPageTreeNodeChromiumWin.cpp:59
>> +                            DWORD flag) {
> 
> You don't need to wrap these lines.
> 
> We had better rename 'buffer' to 'characters', 'length'  to 'charactersLength' because this function has two buffer arguments.

Done.

>> Source/WebCore/platform/graphics/chromium/GlyphPageTreeNodeChromiumWin.cpp:148
>> +                         dc, buffer, length, localGlyphBuffer, GGI_MARK_NONEXISTING_GLYPHS)) {
> 
> You don't need to wrap these lines.

Done.

>>> Source/WebCore/platform/graphics/chromium/GlyphPageTreeNodeChromiumWin.cpp:150
>>> +        ReleaseDC(0, dc);
>> 
>> We had better introduce scoped objects like base/win/scoped_dc.h of Chromium.
>> You don't need to add them in this patch.
> 
> We already have WebCore/platform/win/HwnDC.h for HDC.

Switched to use HWndDC, and,
in preference of avoiding nested GetDC, removed the recursion in fillBMPGlyphs.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list