[Webkit-unassigned] [Bug 76508] [Chromium] Random characters got rendered as empty boxes or with incorrect glyphs even when a font is present

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 18 21:18:08 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=76508


Kent Tamura <tkent at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #123062|review?                     |review+, commit-queue-
               Flag|                            |




--- Comment #5 from Kent Tamura <tkent at chromium.org>  2012-01-18 21:18:08 PST ---
(From update of attachment 123062)
View in context: https://bugs.webkit.org/attachment.cgi?id=123062&action=review

r+. But there are some style issues.

> Source/WebCore/platform/graphics/chromium/GlyphPageTreeNodeChromiumWin.cpp:59
> +static bool getGlyphIndices(HFONT font,
> +                            HDC dc,
> +                            const UChar* buffer,
> +                            unsigned length,
> +                            WORD* glyphBuffer,
> +                            DWORD flag) {

You don't need to wrap these lines.

We had better rename 'buffer' to 'characters', 'length'  to 'charactersLength' because this function has two buffer arguments.

> Source/WebCore/platform/graphics/chromium/GlyphPageTreeNodeChromiumWin.cpp:148
> +    if (!getGlyphIndices(fontData->platformData().hfont(),
> +                         dc, buffer, length, localGlyphBuffer, GGI_MARK_NONEXISTING_GLYPHS)) {

You don't need to wrap these lines.

> Source/WebCore/platform/graphics/chromium/GlyphPageTreeNodeChromiumWin.cpp:150
> +        SelectObject(dc, oldFont);
> +        ReleaseDC(0, dc);

We had better introduce scoped objects like base/win/scoped_dc.h of Chromium.
You don't need to add them in this patch.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list