[Webkit-unassigned] [Bug 76571] Add fixed point types for sub-pixel layout

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 18 14:53:38 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=76571


WebKit Review Bot <webkit.review.bot at gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |webkit.review.bot at gmail.com




--- Comment #2 from WebKit Review Bot <webkit.review.bot at gmail.com>  2012-01-18 14:53:38 PST ---
Attachment 123002 did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/CMakeLists.txt', u'Source/W..." exit_code: 1

Source/WebCore/platform/graphics/FixedRect.cpp:37:  Use 'using namespace std;' instead of 'using std::max;'.  [build/using_std] [4]
Source/WebCore/platform/graphics/FixedRect.cpp:38:  Use 'using namespace std;' instead of 'using std::min;'.  [build/using_std] [4]
Source/WebCore/platform/graphics/IntRect.h:85:  The parameter name "rect" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/platform/graphics/FloatSize.h:70:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Source/WebCore/platform/graphics/FloatSize.h:71:  Boolean expressions that span multiple lines should have their operators on the left side of the line instead of the right side.  [whitespace/operators] [4]
Source/WebCore/platform/graphics/FixedSize.h:214:  The parameter name "s" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/platform/graphics/FixedSize.h:214:  The parameter name "p" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/platform/graphics/FloatPoint.cpp:32:  Alphabetical sorting problem.  [build/include_order] [4]
Source/WebCore/platform/AppUnit.h:35:  Alphabetical sorting problem.  [build/include_order] [4]
Source/WebCore/platform/AppUnit.h:77:  wtf_ceil is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/platform/AppUnit.h:86:  An else statement can be removed when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
Source/WebCore/platform/AppUnit.h:276:  This { should be at the end of the previous line  [whitespace/braces] [4]
Source/WebCore/platform/AppUnit.h:275:  An else if statement should be written as an if statement when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
Source/WebCore/platform/AppUnit.h:345:  Missing spaces around /  [whitespace/operators] [3]
Source/WebCore/platform/AppUnit.h:355:  Missing spaces around /  [whitespace/operators] [3]
Source/WebCore/platform/AppUnit.h:360:  Missing spaces around /  [whitespace/operators] [3]
Source/WebCore/platform/AppUnit.h:365:  Missing spaces around /  [whitespace/operators] [3]
Source/WebCore/platform/AppUnit.h:370:  Missing spaces around /  [whitespace/operators] [3]
Source/WebCore/platform/AppUnit.h:375:  Missing spaces around /  [whitespace/operators] [3]
Source/WebCore/platform/AppUnit.h:380:  Missing spaces around /  [whitespace/operators] [3]
Source/WebCore/platform/AppUnit.h:385:  Missing spaces around /  [whitespace/operators] [3]
Source/WebCore/platform/graphics/FixedSize.cpp:38:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Source/WebCore/platform/graphics/FixedRect.h:92:  The parameter name "rect" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 23 in 32 files


If any of these errors are false positives, please file a bug against check-webkit-style.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list