[Webkit-unassigned] [Bug 53644] [GTK] editing/deleting/5408255.html results are incorrect

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jan 12 11:24:15 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=53644


Martin Robinson <mrobinson at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #120476|                            |review-
               Flag|                            |




--- Comment #14 from Martin Robinson <mrobinson at webkit.org>  2012-01-12 11:24:14 PST ---
(From update of attachment 120476)
View in context: https://bugs.webkit.org/attachment.cgi?id=120476&action=review

Okay. This seems like a nice fix. r- here because it should be possible to get something close-to-right on Windows without building and because this breaks WebKitTestRunner. Let me know if you need tips for testing WKTR.

> Source/WebCore/platform/graphics/gtk/ImageGtk.cpp:51
> +static const char* getDataPathForResource()

You need to fix this up a bit. The signature should be: static char* getDataPathForResource(const char* resource). Later on you should use the resource name to find the image.

> Source/WebCore/platform/graphics/gtk/ImageGtk.cpp:78
> +static char* getDataPathForResource(char* resource)

You should probably rename this to something like getPathToImage now. The argument should be a const char*.

> Tools/GNUmakefile.am:76
> +	-DTOP_LEVEL_DIR=\"${shell pwd}/${srcdir}\" \

You need to do something similar for WebKitTestRunner too if you are going to no longer set this environment variable.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list