[Webkit-unassigned] [Bug 75645] WebPlugins can't add items to context menus.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 9 08:37:49 PST 2012


--- Comment #6 from Darin Fisher (:fishd, Google) <fishd at chromium.org>  2012-01-09 08:37:49 PST ---
(From update of attachment 121557)
View in context: https://bugs.webkit.org/attachment.cgi?id=121557&action=review

> Source/WebKit/chromium/public/WebMediaPlayerAction.h:43
> +        Rotate90CW,

When we spoke about this design in person, I hadn't considered the fact
that this enum would also grow.  This one is very specifically about the
media player.  That's problematic since the media player doesn't support
rotation.  Same goes for WebView::performMediaPlayerAction.  It doesn't
seem correct to graft plugin-related command handling onto that.

Since it seems OK to refer to plugins as media, maybe the answer is to just
use more generic names for WebMediaPlayerAction and performMediaPlayerAction?
WebMediaAction and performMediaAction?

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list