[Webkit-unassigned] [Bug 75657] WTF::yield() conflicts with unistd.h when building with Solaris Studio 12.3

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 6 14:32:04 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=75657





--- Comment #6 from Michael Nordman <michaeln at google.com>  2012-01-06 14:32:04 PST ---
(In reply to comment #5)
> > Maybe the answer is: Feel free to submit a patch which removes the "using" statement and changes SQLiteDatabase.cpp to WTF::yield?
> 
> I don't think that this is the best solution. We export all public functions from WTF into global namespace, so having an exception because of a rare platform seems wrong.

Interesting that this comes up with the "[chromium-dev] Pros and cons of "using namespace" (WAS: Consensus on when to use "using" directives)" discussion active.

> Renaming the function or removing it altogether seems better.

Feel free to submit a patch which removes the "using" statement and explicitly calls WTF::yeild, or to rename it to something that doesn't collide like wtfYield(). Pretty clear that yield() is used here to prevent this method from starving other threads of cpu. It's probably not a good idea to just remove it.

120    void SQLiteDatabase::interrupt()
121    {
122        m_interrupted = true;
123        while (!m_lockingMutex.tryLock()) {
124            MutexLocker locker(m_databaseClosingMutex);
125            if (!m_db)
126                return;
127            sqlite3_interrupt(m_db);
128            yield();
129        }
130    
131        m_lockingMutex.unlock();
132    }

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list