[Webkit-unassigned] [Bug 75657] WTF::yield() conflicts with unistd.h when building with Solaris Studio 12.3

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 6 14:17:00 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=75657





--- Comment #4 from David Levin <levin at chromium.org>  2012-01-06 14:17:00 PST ---
(In reply to comment #3)
> (In reply to comment #2)
> > Michael, do you know why the yield statement is needed in the sql code from bug 42843?
> > 
> > Could it be removed? (Or replace with something else?)
> 
> Looks like the problem is that "using WTF::yeild" in a .h file puts a very generic function name in the global namespace. We could change the name of the WTF::yeild() function to be less generic. Or better yet, avoid 'using' it and require callers (ap says there's only one) to fully qualify the function name.

Michael, here is the one instance:   http://trac.webkit.org/browser/trunk/Source/WebCore/platform/sql/SQLiteDatabase.cpp#L128

which is why I was asking you :).

Maybe the answer is: Feel free to submit a patch which removes the "using" statement and changes SQLiteDatabase.cpp to WTF::yield?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list