[Webkit-unassigned] [Bug 75243] [EFL] Refactor single backing store scroll code.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 4 19:16:23 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=75243





--- Comment #5 from JungJik Lee <jungjik.lee at samsung.com>  2012-01-04 19:16:23 PST ---
(In reply to comment #4)
> > Source/WebKit/efl/ewk/ewk_view_single.cpp:91
> > +static inline void _ewk_view_reverse_line_move(uint32_t* destination, uint32_t* source, size_t count)
> 
> conut can be const variable.
> 
I've changed them to const value.

> > Source/WebKit/efl/ewk/ewk_view_single.cpp:105
> > +    const bool moveLineLeft = sourceX >= destinationX ? true : false;
> 
I was considering readability, anyway I've changed it.

> sourceX >= destinationX can be true or false. onst bool moveLineLeft = sourceX >= destinationX; would be fine.
> 
> > Source/WebKit/efl/ewk/ewk_view_single.cpp:112
> > +        destination = destinationBegin + (frameWidth * startHeight);
> 
> Why don't you reduce same calculation ? => (frameWidth * startHeight)
> 
To do so, I have to have another variable to save the value in the loop.

> > Source/WebKit/efl/ewk/ewk_view_single.cpp:115
> > +        if (moveLineLeft)
> 
> If you can put the comparison condition outside of for loop, it can reduce cost of repetition of fixed condition check.
> 
It cannot be outside of the loop so I leave it.

> > Source/WebKit/efl/ewk/ewk_view_single.cpp:116
> > +            memcpy(destination, source, copyWidth * 4);
> 
> I suggest you to put copyWidth * 4 outside of for loop.
> 
I fixed it,too.

> > Source/WebKit/efl/ewk/ewk_view_single.cpp:171
> > +
> 
> U better put vas_object_image_data_update_add(smartData->backing_store, destinationX, destinationY, copyWidth, copyHeight) in here.
I moved it close to _ewk_view_screen_move

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list