[Webkit-unassigned] [Bug 63062] Add capture attribute for HTML Media Capture

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 27 04:53:20 PST 2012


--- Comment #44 from Ben Murdoch <benm at google.com>  2012-02-27 04:53:18 PST ---
(From update of attachment 127914)
View in context: https://bugs.webkit.org/attachment.cgi?id=127914&action=review

Thanks for the latest patch Jongseok!

> Source/WebCore/html/FileInputType.cpp:163
> +            chrome->runOpenPanel(input->document()->frame(), newFileChooser(settings));

As per Kent Tamura's comment, we should only use runCapturePanel #if ENABLE(MEDIA_CAPTURE). Each platform can implement runCapturePanel as it wants to, which may then call runOpenPanel if type == filesystem for example. That's up to the embedder.

> Source/WebCore/platform/FileChooser.cpp:70
> +        return NonCapture;

return FileSystem here as that is the default according to the spec?

> Source/WebCore/platform/FileChooser.cpp:76
> +            if ((capture.isEmpty() || equalIgnoringCase(capture, MediaCaptureNames::camera()))

Why if capture.isEmpty()? This means that if you specify accept="image/*" then we'll always default to the camera? I can't see where the spec says to do that.

> Source/WebCore/platform/FileChooser.cpp:77
> +                && (*iterator).startsWith("image/"))

I think this might be a bit easier to read if you checked the mime type first, i.e.
if (*iterator.startsWith("image/*") && equalsIgnoringCase(capture, MediaCaptureNames::camera()) ...

What do you think?

> Source/WebCore/platform/FileChooser.cpp:86
> +            if (type == NonCapture)

initialise type to FileSystem on line 72 and no need for this?

> Source/WebCore/platform/FileChooser.h:46
> +    NonCapture,

I don't think we need this one.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list