[Webkit-unassigned] [Bug 79608] Getting the instruction stream for a code block should not require two loads

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Feb 26 15:48:03 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=79608


Sam Weinig <sam at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #128930|review?                     |review+
               Flag|                            |




--- Comment #11 from Sam Weinig <sam at webkit.org>  2012-02-26 15:48:03 PST ---
(From update of attachment 128930)
View in context: https://bugs.webkit.org/attachment.cgi?id=128930&action=review

In addition to the rename and comment fix.  Please consider adding basic unit tests to TestWebKitAPI.

> Source/JavaScriptCore/ChangeLog:16
> +        This patch also gets rid of the bytecode discarding logic, since we don't
> +        use it anymore and it's unlikely to ever work right with DFG or LLInt. And
> +        I didn't feel like porting dead code to use CompactVector.

Sadness.

> Source/JavaScriptCore/wtf/CompactVector.h:33
> +// This implements a resizeable array for POD** values, which is optimized for:

This isn't actually resizable.

> Source/JavaScriptCore/wtf/CompactVector.h:47
> +template<typename T>
> +class CompactVector {

I think this name is misleading.  Really, this is just an array with an efficiently RefCounted data part.  RefCountedArray?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list