[Webkit-unassigned] [Bug 79521] [Qt][WK2] Use movementStarted/Ended signals instead of movingChanged on QtViewportInterationEngine

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Feb 25 05:13:50 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=79521


Kenneth Rohde Christiansen <kenneth at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #128787|review?                     |review-
               Flag|                            |




--- Comment #2 from Kenneth Rohde Christiansen <kenneth at webkit.org>  2012-02-25 05:13:50 PST ---
(From update of attachment 128787)
View in context: https://bugs.webkit.org/attachment.cgi?id=128787&action=review

Almost there!

> Source/WebKit2/UIProcess/qt/QtViewportInteractionEngine.cpp:129
> +    connect(m_flickProvider, SIGNAL(movementStarted()), SLOT(panMoveStarted()), Qt::DirectConnection);
> +    connect(m_flickProvider, SIGNAL(movementEnded()), SLOT(panMoveEnded()), Qt::DirectConnection);

I think we should rename those methods to flickableMoveStarted/Ended

> Source/WebKit2/UIProcess/qt/QtViewportInteractionEngine.cpp:-193
> -    if (m_flickProvider->isMoving()) {
> -        if (m_scrollUpdateDeferrer)

Can be please assert for this inside the panMoveStarted/Ended to ensure that the state is always correct?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list