[Webkit-unassigned] [Bug 72173] Pause the media element for exiting TextTrackCues when pauseOnExit is set

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 21 07:37:16 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=72173





--- Comment #7 from Eric Carlson <eric.carlson at apple.com>  2012-02-21 07:37:16 PST ---
(In reply to comment #5)
> (In reply to comment #3)
> > (From update of attachment 127844 [details] [details])
> > View in context: https://bugs.webkit.org/attachment.cgi?id=127844&action=review
> > 
> > > Source/WebCore/html/HTMLMediaElement.cpp:1061
> > > +    for (size_t i = 0; !m_paused && i < previousCues.size(); ++i) {
> > 
> > Nit: is there any reason to not use previousCuesSize instead of previousCues.size()?
> 
> I'm just worried about readability - maybe I should change the function call everywhere within the method? But isn't the Vector::size() function call itself cheap? It seems to be just a const method returning a member variable.

I see now that most of the loops in updateActiveTextTrackCues don't cache the vector size before the loop. One way or the other, we should try to be consistent.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list