[Webkit-unassigned] [Bug 79063] MathML internals - code clean-up for RenderMathMLSubSup

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 20 19:20:10 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=79063





--- Comment #2 from Eric Seidel <eric at webkit.org>  2012-02-20 19:20:10 PST ---
(From update of attachment 127890)
View in context: https://bugs.webkit.org/attachment.cgi?id=127890&action=review

I think this is OK, but could be made a bit more clear.  Are you willing to go another round of cleanup before moving foward?

> Source/WebCore/rendering/mathml/RenderMathMLSubSup.cpp:-149
> -                if (top->isBoxModelObject()) {
> -                    RenderBoxModelObject* topBox = toRenderBoxModelObject(top);
> -                    topBox->updateBoxModelInfoFromStyle();
> -                }

We no longer need this update?

> Source/WebCore/rendering/mathml/RenderMathMLSubSup.cpp:151
> +    if (m_kind == SubSup && m_scripts) {

It would be better to early return so we didn't have to indent the whole rest of this function?

> Source/WebCore/rendering/mathml/RenderMathMLSubSup.cpp:153
> +            LayoutUnit heightDiff = (m_scripts->offsetHeight() - base->offsetHeight()) / 2;

heightDiff sounds like a strange name for this half-height diff?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list