[Webkit-unassigned] [Bug 78180] MathML internals for bug 52444 fix - type checking, PassRefPtr

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Feb 9 10:01:01 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=78180


Eric Seidel <eric at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #126195|review?, commit-queue?      |review+, commit-queue+
               Flag|                            |




--- Comment #9 from Eric Seidel <eric at webkit.org>  2012-02-09 10:01:01 PST ---
(From update of attachment 126195)
View in context: https://bugs.webkit.org/attachment.cgi?id=126195&action=review

LGTM.  Keep them coming.  This code needs lots of love.

> Source/WebCore/rendering/mathml/RenderMathMLFenced.cpp:83
> +PassRefPtr<RenderStyle> RenderMathMLFenced::makeOperatorStyle()

This should probably be renamed createOperatorStyle() (to follow the CreateRule, which the ReftPtr (and Mac OS X style docs) talk about.  That doesn't have to be today, or in this patch.

> Source/WebCore/rendering/mathml/RenderMathMLOperator.cpp:48
> -RenderMathMLOperator::RenderMathMLOperator(Node* container, UChar operatorChar)
> -    : RenderMathMLBlock(container)
> +RenderMathMLOperator::RenderMathMLOperator(Node* node, UChar operatorChar)

Odd that these took nodes to begin with, since it would never make sense for a Comment or Document node to be involved in a MathML rendering tree.  (Nodes can't even have style, so they couldn't be styled to look like mathtml..)

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list