[Webkit-unassigned] [Bug 78191] New: WebCore::Range's setStart() and setEnd() should be called with exception code variable

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Feb 8 18:29:35 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=78191

           Summary: WebCore::Range's setStart() and setEnd() should be
                    called with exception code variable
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: All
        OS/Version: Other
            Status: UNCONFIRMED
          Severity: Normal
          Priority: P2
         Component: HTML DOM
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: xuewen.wang at torchmobile.com.cn


The declaration of WebCore::Range::setStart and WebCore::Range::setEnd are:
    void setStart(PassRefPtr<Node> container, int offset, ExceptionCode& = ASSERT_NO_EXCEPTION);
    void setEnd(PassRefPtr<Node> container, int offset, ExceptionCode& = ASSERT_NO_EXCEPTION);
They assert that the exception code parameter should not be bypassed, but in the WebCore::Range::Range(), it calls them without the ExceptionCode parameter, that will cause an assertion failure.
The code is at Source/WebCore/dom/Range.cpp:94
    setStart(startContainer, startOffset);
    setEnd(endContainer, endOffset);

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list