[Webkit-unassigned] [Bug 75812] JSC should be a triple-tier VM

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 6 17:22:52 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=75812





--- Comment #102 from WebKit Review Bot <webkit.review.bot at gmail.com>  2012-02-06 17:22:47 PST ---
Attachment 125735 did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/CMakeLists.txt', u'S..." exit_code: 1

Last 3072 characters of output:
e underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/llint/LLIntHelpers.cpp:123:  __ct_globalData is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/llint/LLIntHelpers.cpp:129:  __cce_exec is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/llint/LLIntHelpers.cpp:130:  __cce_pc is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/llint/LLIntHelpers.cpp:136:  __cr_exec is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/llint/LLIntHelpers.cpp:137:  __cr_pc is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/llint/LLIntHelpers.cpp:138:  __cr_callTarget is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/llint/LLIntHelpers.cpp:231:  The parameter name "]" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/llint/LLIntHelpers.cpp:1413:  The parameter name "v" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/llint/LLIntHelpers.cpp:1450:  The parameter name "!" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/runtime/StructureChain.h:40:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
Source/JavaScriptCore/runtime/JSTypeInfo.h:37:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
Source/JavaScriptCore/llint/LLIntOffsetsExtractor.cpp:70:  Alphabetical sorting problem.  [build/include_order] [4]
Source/JavaScriptCore/runtime/JSVariableObject.h:41:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
Source/JavaScriptCore/jit/HostCallReturnValue.cpp:40:  Extra space before ( in function call  [whitespace/parens] [4]
Source/JavaScriptCore/jit/HostCallReturnValue.cpp:47:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/jit/HostCallReturnValue.cpp:49:  Extra space before ( in function call  [whitespace/parens] [4]
Source/JavaScriptCore/jit/HostCallReturnValue.cpp:56:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/jit/HostCallReturnValue.cpp:58:  Extra space before ( in function call  [whitespace/parens] [4]
Source/JavaScriptCore/jit/HostCallReturnValue.cpp:69:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/JavaScriptCore/runtime/Structure.h:48:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
Source/JavaScriptCore/llint/LowLevelInterpreter.cpp:36:  Alphabetical sorting problem.  [build/include_order] [4]
Total errors found: 27 in 112 files


If any of these errors are false positives, please file a bug against check-webkit-style.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list